Logitech wireless keyboard problem


We have been using a Logitech Cordless iTouch keyboard with a Dell Dimension 8250. All of a sudden the keyboard does not work. The hardware option on Control Panel says it is working properly (although it does not specifically name this keyboard) and I have unplugged and replugged the USBs on the receiver and a litle balloon indicated that the hardware was installed and ready to use. Still it does not make characters. There is a "connect" button on the reciever and I have pressed it but it seems to me that there should be a connect button on the keyboard itself. I have tried to press various buttons on the keyboard at the same time as the connect button on the reciever but nothing has worked. There is no button on this Logitech Cordles Itouch keyboard that indicates "connect". I have also tried to reboot and to use system restore to no avail? Any help would be appreciated!

Please help.

I didn't find the right solution from the Internet.

Custom animation studio

Página inicial